Storybook – Audio Editing

Audio editing is the second major task when creating a Storybook presentation. Almost all Storybook presentations come with audio that contains narration. It typically arrives embedded in the source PowerPoint file with a single audio file on each slide. Sometimes it is recorded and delivered separately as a set of audio files that correspond to each slide. Less frequently it will arrive as one long recording that you will have to break into chunks. Though we try to steer faculty away from creating one long recording.

Extracting

If narration was recorded in the standard recommended way, then the first step in editing the audio is to extract it from the PowerPoint file. This is relatively straightforward, but with a few gotchas to keep in mind depending on what files have what audio on them.

Preparing for Extracting

To avoid any headaches or confusion, the first thing you should do when extracting audio is: review the presentation. You are looking for slides that do not have audio on them, and for slides that have audio, that is on more than one slide. Both of these situations will throw off the count/labeling of the extracted audio files.

For example, if you have a 10 slide presentation and slides one and two do not have audio on them, you will have a set of audio files numbered from one to eight when you extract them. These extracted audio files will also not be numbered the same as their corresponding slides. This means the audio from slide three will be labeled as one, the audio from slide four will be labeled as two, and so on. You can see how this would get confusing really fast.

A similar thing happens when you have the same audio recording duplicated on multiple slides. For example, you have a 10 slide presentation but slides two, three, and four all share the same audio recording because your instructional designer decided to ask for the audio to be sliced up into three parts to be spread over those slides. When you extract the audio you will find there are not three copies of the audio. You will find you have eight audio files numbered one through eight. And the audio from slide five is now labeled as three and the audio from slide six is not labeled as four, and so on up to eight.

The solution to both of these issues is to quickly record small dummy recordings on every slide that is audio-less or has duplicate audio of a previous slide.

Slides with Missing Audio

On each slide that does not have an audio recording, do the following:

  1. Navigate to the Insert tab of the Ribbon
  2. From the menu that appears when you click the Audio button, select Record Audio…, a recording dialog will appear.
  3. Click the red record button to record a second of dummy audio.
  4. Click the stop button after the second has passed.
  5. Click Insert to add the dummy audio recording to the slide.
  6. Repeat for every slide that needs dummy audio
  7. Save the PowerPoint file.

Slides with Duplicate Audio

For presentations that contain duplicate audio on multiple slides you will need to remove all duplicate instances of the audio, and record dummy audio recordings in their place:

  1. Navigate to the second instance of a duplicated audio recording (If slide two and three have the same audio, navigate to slide three)
  2. Select the audio recording on the slide and delete it.
  3. Navigate to the Insert tab of the Ribbon
  4. From the menu that appears when you click the Audio button, select Record Audio…, a recording dialog will appear.
  5. Click the red record button to record a second of dummy audio.
  6. Click the stop button after the second has passed.
  7. Click Insert to add the dummy audio recording to the slide.
  8. Repeat for every slide that has a duplicate audio recording and needs dummy audio
  9. Save the PowerPoint file.

Extraction Process

Now that your source PowerPoint file has had its audio reviewed, and you have made all the necessary dummy recordings (if needed), you are ready to extract the audio files.

There are two common ways to go about extracting audio:

The Unarchiver Method

The simplest and quickest way to extract a PowerPoint file is to use an application you can install called The Unarchiver. You can find it on our Storybook Production Tools documentation page. Once it is installed, do the following:

  1. Right click the PowerPoint file you will be extracting audio from and choose Open With then The Unarchiver
  2. In the resulting extracted folder, navigate to ppt > media.
  3. Move the audio files found in the media folder into an audio folder inside of the dev folder of the Storybook project you are working on.
  4. Delete the dummy recordings
  5. Delete the extracted folder

Renaming Method

  1. Duplicate the source PowerPoint file that contains the audio you want to extract
  2. Rename the duplicate changing the file extension of .pptx to .zip. When the Finder asks if you really want to, click Use .zip.
  3. Double click the newly renamed .zip file to extract it.
  4. In the resulting extracted folder, navigate to ppt > media.
  5. Move the audio files found in the media folder into the /dev/audio folder inside of the Storybook project you are working on.
  6. Delete the dummy recordings
  7. Delete the renamed .zip version of the PowerPoint project
  8. Delete the extracted folder

Preparing to Edit the Audio

Now that you have the audio files extracted there is one more step before beginning to edit them. All of the audio files should be converted to WAV format for editing. This will both be the copy you edit, and the version that is stored for backup should further edits or exports of the audio be required in the future. Think of these WAV files as the “masters” we can export new copies of the narration from. Conversion can be accomplished by running all of the files through Adobe Media Encoder.

If you happen to find WMA audio files in a presentation, send them over to Bryan to have them converted to WAV. Sadly Adobe Products can’t read them even though they can export them. DO NOT download any audio/video conversion/extraction software from the internet. These are common vectors for malware and viruses.

Conversion Steps

  1. Open Adobe Media Encoder
  2. Clear any items that are currently in the queue
  3. Drag all of your audio files into the window to add them to the queue
  4. Select all of the items in the queue
  5. Set the format to wav
  6. Set the Preset to “WAV 48 kHz 16-bit – Mono” (If you don’t already have this preset, you can download it from the Presets documentation page.)
  7. Set the Output File to your desired location inside of your dev folder
  8. Click the start queue button to begin conversion
  9. Delete the extracted copies (they are still available for re-extraction from the source PowerPoint file)

Editing

Editing consists of removing long stretches of silence, adjusting volume levels, and removing any unwanted background noise clicks or pops. We typically do not have time to listen to all of the audio in all presentations so a lot of this work is done by only looking at the waveform.

We generally do our audio editing in Adobe Audition. This document will discuss the audio editing process in a generic way that applies to whatever audio editing program you are using.

Removing Silence

One of the most common edits that you will do, even on audio that is otherwise pristine, is removing silence from the start, end and sometimes middle of audio files. It is important to do these edits to remove delays and keep the pace of the Storybook presentation feeling good.

Silence at the Beginning

We don’t want there to be a long gap of silence at the beginning of the audio for a Storybook page. This is disruptive to the flow of the presentation and may confuse some users.

  1. Select all but one or two seconds of the silence at the beginning of the audio file
  2. Delete the silence

Silence at the End

Silence at the end of an audio file should be minimized to only a second or so. This will allow Storybook to stop playback in a timely manner and not give the impression that there is still more audio to be played. Be sure to avoid cutting off any of the subtle parts of the end of the final word that is said.

  1. Select all but a second or so of the silence at the end of the audio file
  2. Delete the silence

Reducing Unwanted Noise

Background noise, hiss, and hum are the most common issues with narration sent in by instructors. We can do our best to remove it, but it is more of an art than a science. It will take some practice and experience to get a feel for it. There are multiple techniques to use, but the one most commonly used is the Noise Print / Reduce Noise tools in Audition.

Important: Keep in mind that you can’t always get good noise reduction results. When you reduce background noise you may end up introducing other audio “artifacts” like the speaker sounding like they are underwater, tinny, or otherwise distorted. These issues usually result from being too aggressive with the noise reduction. Another common issue that stems from aggressive noise reduction is a distracting contrast between the newly created silence and the vocals.

In some cases a bit of noise is better than the results you get when trying to remove the noise. Alternatively, if you are having trouble getting good noise reduction results you may have to request the audio be re-recorded better.

The basic Noise Reduction process is as follows:

  1. Select a good sized chunk of consistent background noise in the audio file. Make sure the selection does not have voice or other noises other than the background noise in it.
  2. From the Effects menu select Noise Reduction / Restoration > Capture Noise Print. You now have the noise sampled and ready for processing
  3. Select your whole audio track by pressing Command-A.
  4. From the Effects menu select Noise Reduction / Restoration > Noise Reduction (process)… to bring up the Noise Reduction tool
  5. Set the Noise Reduction slider to about 50%
  6. Click the play button in the lower right of the Noise Reduction tools window to preview the changes
  7. Adjust the Noise Reduction percentage as needed to balance noise reduction and minimize audio artifacts on the voice.
  8. Click Apply to apply the noise reduction

Note: A new tutorial is built into Adobe Audition 2017 that walks you through this process. Choose Adobe Learn… from the Help menu and click Reducing background noise to start it.

It’s important to reiterate the fact that noise reduction is not a simple thing and sometimes requires trying different techniques. We have access to a single copy of a more advanced audio cleanup tool called iZotope for difficult noise reduction tasks. There are also other features to try inside of Audition that may give better results depending on the type of noise you are dealing with. Common ones to try are DeHummer, Hiss Reduction and various EQ filters.

Removing Other Noises

Apart from background noise and hum, you will find there are other noises that are worth removing from narration. Commonly these are loud sudden noises that are able to be seen as spikes in the waveform that are more dramatic than the rest. These can be loud lip smacks, coughs, objects bumping of blowing on the microphone or other sudden noises. They should be removed whenever they are noticed.

There are two ways to remove or mitigate the effects of sudden noises or clicks and pops. The first is to just select the noise in question and then delete it. The second is to use the auto-heal feature of Adobe Audition. When doing either of these things, be sure to make as small of a selection as possible to both preserve the pace of the audio, and in the case of auto-heal, to make sure you get good results. Auto-heal can be useful when the noise occurs during someone speaking, but it sometimes produces unwanted audio artifacts.

Delete
  1. Select the noise to be deleted, taking care not to select too much surrounding audio
  2. Press delete on your keyboard
Auto Heal
  1. Select the noise to be removed, taking care to only select the part of the waveform representing the sound.
  2. Right-click on the waveform and select Auto Heal Selection. Or press Command-U
  3. Listen to the result and check it for unwanted audio artifacts

Overall Volume Level

Maybe the most obvious thing that needs attention when editing audio is volume level. Sometimes this can seem tricky to balance. But generally, we are just going for consistency in average volume across the whole presentation. We also want to make sure that levels are consistent within a recording, so bits of the narration are not dramatically louder than the rest. Sometimes an instructor changes their tone of voice frequently, or they have a sibilant or strong S sound in their voice. These things need to be addressed to provide a comfortable listening experience for students.

Generally it is a good idea to target your volume levels to be peaking around -6db. This can be done by raising or lowering the overall volume of the audio track. While listening to the audio to get a sense of the volume it is playing back at is important. It is possible to use the waveform, the dB scale, and the meters to visually know your audio is in the right range.

The UV meters

These are the meters that bounce up and down while playing back the audio. Generally we want our audio to be bouncing into the yellow and rarely into the red. We definitely don’t want it hitting the top of the meter or “clipping.”

The Decibel Scale and Waveform

To the right of the waveform you will see a scale that lists the decibel or dB that the waveform is reaching. You can set a zoom level for this scale by scrolling your mouse wheel while your cursor is hovering over it. Changing the scale changes the appearance (apparent scale) of the waveform. I recommend never changing this zoom level. You can reset it by right-clicking on the scale and choosing Zoom Reset (Amplitude).

Raising

Raising the overall volume can be done by selecting the whole waveform and dragging the volume adjustment slider that floats above the waveform in the editor. This can be used to bring up the volume of audio that might be a little low. Note that you should not increase the volume of quiet audio too much as it might raise the quiet noise that is in the background too high.

Compressor

The best way to lower audio that is too loud is to use the compressor. This will analyze the audio and bring down parts that go over a certain threshold to give the audio file a more even sound. This is better than just selecting all of the audio and lowering it as it means you won’t accidentally make some parts too low.

The Single-band Compressor can be found in the Effects menu under Amplitude and Compression > Single-band Compressor…. There many ways to set up a compressor to even out the levels of an audio track, but I find that the settings depicted in the screenshot below should work pretty good.

Threshold
is the level at which anything above it will start to be affected by the compressor.
Ratio
is how much the audio will be lowered when the compressor acts on the audio.
Attack
is how fast the compressor will respond to increases in audio levels.
Release
is how quickly after the audio falls below the threshold it will stop affecting the audio
Output gain
will raise or lower the overall volume of the audio regardless of Threshold settings.

Again, these are settings you can tweak but they should work pretty well in general.

De-essing

De-essing is another common filter that can be applied to audio to help level out the volume. It is found in the Effects menu under Amplitude and Compression > DeEsser…. De-essing will look for situations where a sharp Ess noise happens and try to lower the volume of just that sound. Depending on the microphone and the voice of the speaker they may have a lot of sharp/loud ess sounds in their speech. The deesser is not a magic solution that can remove the unwanted sound, it can only lower it. And in some cases, it is hard to get it to lower it as much as you would like. The De-esser takes a lot of experimenting to get results.

Generally it works OK to playback the audio while the De-esser is open and watch the waveform while it plays looking for the times when the ess noises happen and where the waveform spikes. You then can know where to set the Center Frequency and how wide the Bandwidth needs to be.

Threshold
Just like the compressor, this is the level above which the filter will start affecting the audio.
Center Frequency
The center of the peak of the ess noise
Bandwidth
How wide the selection of affected frequencies is.

Export

So, now you are all done editing the audio for the presentation. You have an edited WAV file for each Storybook page and are ready to convert them for use in the project. You can close Audition and open up Adobe Media Encoder to do a bulk conversion to MP3.

  1. Clear the Queue
  2. Drag all of the edited wav files into the Media Encoder Window
  3. Select all of the items in the queue so that when you apply settings to one of them, they will all receive the same settings
  4. Set the format to MP3
  5. Set the Preset to MP3 64 kbps – Mono for narration or MP3 128 kbps – Stereo if music is involved. (If you don’t already have these presets, you can learn how to make it on the documentation page for Presets)
  6. Set the Output file to the fin/[storybook_project]/assets/audio folder
  7. Click the green Start Queue button to begin exporting your MP3s

Slide Formatting Storybook Assembly

Published on April 24, 2017 at 3:15:24 pm CST. Last modified on May 30, 2018 at 1:00:28 pm CST.